7th February 2026

Piopio Mangaotaki outage

We currently have an outage at our Mangaotaki repeater site. The teams are investigating and hope to resolve soon

Update A technician is on their way to site. ETA is 16:45

Update 18:00 We have identified a failed radio, a replacement is enroute to site.

Update 19:40 Equipment has been replaced and services have been restored.