16th November 2023

VoIP Phone Services Cloud Phone System Issues.

We are experiencing an issue with our cloud phone system provider causing phone systems to become inoperable.

The team are looking into this ASAP and will update this page with any further info.

Update: 14:05 The situation is improving, although not as quickly as we had hoped. Be assured though that Yealink are all over this and working as fast as they can to get it completely resolved.

Update 9:30 The systems have been restored. Our team will remove redirects at 9am 17/11 incase there are issues overnight.