13th April 2022

Mangaotaki Upgrade, scheduled 2 months ago

If the weather holds out we are looking to upgrade our main Magaotaki feed dish. This will cause an outage for customers connected to our Mangaotaki site.

Update: 16:04 - Technicians have replaced the main backhaul, how ever the site remains offline. The team are heading to the Mangaotaki end to inspect.

Update 17:55 - Upgrades have been completed.